Specific Guide Bug Reporting

Ludovicus's picture





To submit a bug for a specific guide, please choose the guide you would like to submit a bug for from the table below.

When submitting your bug, you MUST include the following:

  • The version number of your WoW-Pro installation
  • Any error text that WoW provided when your bug happened
  • What step you were on
  • As many details as possible about what you were doing when the bug occurred.

Including this information will help us troubleshoot and possibly get you a temporary solution to the bug, and get it fixed as quickly as possible!

Comments

Valley of the Four Winds

I know this ones brand new just found that when I reached "The Golden Dream" the quest did not appear until I completed "Ashyo's Vision".  I love these guides by the way.  Thank you for all the hard work.

actually that fire is in the

actually that fire is in the guide, just it still says borean tundrea on it (I think...) the guide points you there after you do the 1st two in BT (alliance / horde) then it still say desicrate this fire in BT, but it's mapped to DB

you seem to be right

The "(Borean Tundra)" for the Horde fire in Borean Tundra is missing, and the (Dragonblight) from the Dragonblight fire is reading "(Borean Tundra)"...

Midsummer Festival Guide Alliance

First of all, "N Keep Going? |N|Time to head to Dalaran to get that last achievment
needed for the Flame Warden meta achievement Also, do you need more
blossoms and cash? Hit up the Northrend bonfires, though they do not
count for any type of achivement.|QID|13485" is factually incorrect since the Northrend fires now do count towards the meta and have their own two sub-metas.

Secondly,
the Horde bonfire in Dragonblight is missing. I'm not sure how the
correct syntax is, especially I have not idea what the QID wis, but the
rest would be something along the lines of "A Desecrate this Fire|N|At the Horde Bonfire. (Dragonblight)||[...]|M|38.6,48.4|Z|Dragonblight|"

Ludovicus's picture

Re: Midsummer Festival Guide Alliance

Some edits by Laoteu and myself should have this fixed:

http://wow-pro.com/node/3406/revisions

 

 

thank you very much

Looks fixed to me now. :)

Exploration - Eastern Plaquelands

Sorry if I'm doing this wrong but, the Exploration Guide is looking for 'Eastern Plaqueland' map, not 'lands'.  It is missing the "s"

Ludovicus's picture

Re: Exploration - Eastern Plaquelands

Not advancing after cinematic

I've noticed that the quest steps don't advance after a cinematic.  In the same way it does with combat scene, where it shows like 1/1 for the steps and a tick in the box, it doesn't advance.  This I've noticed in Uldum where there's quite a few cinematics.

Back in Uldum, and I'm

Back in Uldum, and I'm noticing this is still happening, any ideas?

Daily Quests Wildhammer

I'm getting this error when loading the ui and the wildhammer dailies will not load.

P.S. your CAPTCHA is horrible.  I have to expand the page to 210 percent to see those tiny letters.

Message: Interface\AddOns\WoWPro\WoWPro.lua:273: attempt to index field 'EventFrame' (a nil value)
Time: 07/07/11 18:22:04
Count: 1
Stack: Interface\AddOns\WoWPro\WoWPro.lua:273: in function `RegisterEvents'
Interface\AddOns\WoWPro_Dailies\WoWPro_Dailies.lua:24: in function
(tail call): ?
[C]: ?
[string "safecall Dispatcher[1]"]:9: in function <[string "safecall Dispatcher[1]"]:5>
(tail call): ?
...ddOns\WoWPro\Libraries\AceAddon-3.0\AceAddon-3.0.lua:543: in function `EnableAddon'
...ddOns\WoWPro\Libraries\AceAddon-3.0\AceAddon-3.0.lua:635: in function <...ddOns\WoWPro\Libraries\AceAddon-3.0\AceAddon-3.0.lua:621>
[C]: in function `LoadAddOn'
[string "Interface\FrameXML\BasicControls.xml:
(tail call): ?
Interface\AddOns\WoWPro\WoWPro.lua:113: in function
(tail call): ?
[C]: ?
[string "safecall Dispatcher[1]"]:9: in function <[string "safecall Dispatcher[1]"]:5>
(tail call): ?
...ddOns\WoWPro\Libraries\AceAddon-3.0\AceAddon-3.0.lua:543: in function `EnableAddon'
...ddOns\WoWPro\Libraries\AceAddon-3.0\AceAddon-3.0.lua:635: in function <...ddOns\WoWPro\Libraries\AceAddon-3.0\AceAddon-3.0.lua:621>
[C]: in function `LoadAddOn'
Interface\FrameXML\UIParent.lua:259: in function `UIParentLoadAddOn'
Interface\FrameXML\UIParent.lua:333: in function `TimeManager_LoadUI'
Interface\FrameXML\UIParent.lua:556: in function

Locals:

Ludovicus's picture

Daily Quests Wildhammer: Multiple Failures

RagManiac:

Since you seem to be running Swatter, could you see if you have an error before the error you showed us?

It looks like the base addon, WoWPro improperly initialized.   It is the first error after you log in that is the key.

Doing a "/swat clear" and the logging out and then back in should clear the log and then show you how many errors.

 

 

Daily Quests Wildhammer: Multiple Failures

Followed your advice.

Ran "/swat clear" got the response that swatter log was cleared.

Swatter reported no errors with only wow-pro and tomtom loaded.

I've had no problems with wow-pro until the newest version was used with world events on it.

I'm trying to use the Dailies Wildhammer Clan daily chain.  I think that WoW-Pro thinks that it is a one-time use quest chain and doesn't reset.  The WHC chain cannot be clicked after completing it once, it cannot be selected in order to use the reset button either.

     I also want to know why WoW-Pro worked with Carbonite in the previous versions (it has tomtom emulator) and it doesn't work with it now?  Carbonite is INCREDIBLY useful.  It's available at curse wow interface and the homepage is carboniteaddon dot com.  I'm sure you're familiar with it.

 

Crackerhead22's picture

It is very strange that

It is very strange that Carbonite is not working right with the addon, I know there will be text saying to grab TomTom (which I think someone is working on getting rid of if you have Carbonite as well).

Wildhammer Clan

This happens when loading WoW-Pro, and Carbonite only. Addon Control Panel is standard.

Date: 2011-07-09 09:19:06
ID: 1
Error occured in: Global
Count: 1
Message: ...Ons\WoWPro_WorldEvents\WoWPro_WorldEvents_Parser.lua line 180:
attempt to index field 'prereq' (a nil value)
Debug:
(tail call): ?
...Ons\WoWPro_WorldEvents\WoWPro_WorldEvents_Parser.lua:180:
...Ons\WoWPro_WorldEvents\WoWPro_WorldEvents_Parser.lua:116
...Ons\WoWPro_WorldEvents\WoWPro_WorldEvents_Parser.lua:212: LoadGuide() WoWPro\WoWPro_Broker.lua:64: LoadGuide()
...ace\AddOns\WoWPro_WorldEvents\WoWPro_WorldEvents.lua:42:
...ace\AddOns\WoWPro_WorldEvents\WoWPro_WorldEvents.lua:17
(tail call): ?
[C]: ?
[string "safecall Dispatcher[1]"]:9:
[string "safecall Dispatcher[1]"]:5
(tail call): ?
...ddOns\WoWPro\Libraries\AceAddon-3.0\AceAddon-3.0.lua:543:
...ddOns\WoWPro\Libraries\AceAddon-3.0\AceAddon-3.0.lua:536
(tail call): ?
WoWPro\WoWPro.lua:139:
WoWPro\WoWPro.lua:103
(tail call): ?
[C]: ?
[string "safecall Dispatcher[1]"]:9:
[string "safecall Dispatcher[1]"]:5
(tail call): ?
...ddOns\WoWPro\Libraries\AceAddon-3.0\AceAddon-3.0.lua:543: EnableAddon()
...ddOns\WoWPro\Libraries\AceAddon-3.0\AceAddon-3.0.lua:635:
...ddOns\WoWPro\Libraries\AceAddon-3.0\AceAddon-3.0.lua:621
[C]: LoadAddOn()
..\FrameXML\UIParent.lua:259: UIParentLoadAddOn()
..\FrameXML\UIParent.lua:333: TimeManager_LoadUI()
..\FrameXML\UIParent.lua:556:
..\FrameXML\UIParent.lua:531
AddOns:
Swatter, v5.11.5146 (DangerousDingo)
ACP, v3.3.16
Carbonite, v4.2
CarboniteTransfer, v1.01
WoWPro, v2.1.17
WoWProDailies, v2.1.17
WoWProLeveling, v2.1.17
WowProProfession, v2.1.17
WoWProWorldEvents, v2.1.17
BlizRuntimeLib_enUS v4.2.0.40200
(ck=10a)

Crackerhead22's picture

Try disabling the WoWPro

Try disabling the WoWPro World Events module.  I thought I had got rid of that...  Ugh, time to try and figure it out.

EDIT: I think I left a line in there that shouldn't be there.  Try deleting line 180 in the WoWPro_WorldEvents_Parser.lua  "WoWPro.prereq[i] = text:match("|PRE|([^|]*)|?")"

Re: disable world events

No fix, this still brought up the error.

The main point is that the Wildhammer dailies don't work.

Crackerhead22's picture

The only other thing I can

The only other thing I can think of is reseting the guide (Shift+Click on the guide in the list).  I just tried the Wildhammer guide myself and had no errors.

errors are not showing up right.

for some reason the text editor is collapsing my errors so they run one line into the next.

Crackerhead22's picture

Disable rich text editor

Disable rich text editor before pasting them into the thing.

Stonetalon Mountains

I can't see Stonetalon Mountains on this list.

Jiyambi's picture

Fixed, sorry about that!

Fixed, sorry about that!

kayeich's picture

Weird. Jiyambi will fix those

Weird. Jiyambi will fix those when she has a chance, but in the meantime, here are the links to the comment forms for Stonetalon Mts: