WoW-Pro Leveling Addon

Ludovicus's picture





Current Version: 2.7.7
Last Update: Apr 23, 2014
Next Update: June 11, 2014


Still don't believe us? Check out our User Testimonials!





Basic Guide Window

Minimalist View

Dropdown Menu

Guide List

How To Install:

  1. Download the addon using the big shiny button.

  2. Download TomTom from WoW Interface or Curse. TomTom is important! Without it, you won't see the arrow telling you where to go! Get version v50400-1.0.0 or later.
  3. Unzip the downloaded files into your addons directory. (How do I unzip the file?)

    Windows 7/8 location:

      C:\Users\Public\Games\World of Warcraft\Interface\Addons

    Mac location:

      Macintosh Main HD/Applications/World of Warcraft/Interface/Addons
  4. Log into the game. In the lower left-hand corner of your character select screen, you should see an "Addons" button. Click it. The WoW-Pro addon and TomTom should both be listed. Make sure they are checked, and you're ready to go!

  5. If you have any trouble installing the guide, stop by our Addon Help Chat Room to get help!

You can also visit the WoW-Pro Leveling Addon Troubleshooting Guide, where you'll find a fix for most common issues.


Don't miss out on updates!






Features:

  • Will cover EVERY zone, not just the "best" ones
  • Automatically checks off steps as you progress through the guide
  • Completely customizable view
  • Arrow and map points show you exactly where to go
  • Adjustable XP settings work with...
    • Heirlooms
    • Recruit-A-Friend
    • Dungeons
    • PvP
  • Works great with partially leveled characters
  • Integrated quest tracker (can be disabled if desired)
  • Integrated quest item buttons
  • Supports step skipping (the guide knows the difference between a skipped step and a completed step)
  • Innovative "sticky steps" help you manage quests you need to complete as you go!


Have a bug to report? Want to help us update guides? Check out our community page!




The Addon Dev Team

Lead Developers:

  • Core Addon: Jiyambi/Silvann/Ludovicus
  • Leveling Module: Jiyambi/Ludovicus
  • Dailies Module: Jiyambi/Twists/Ludovicus
  • Professions Module: Ludovicus

Development Team:

  • Dunevon
  • Gameldar
  • Gylin
  • Jiyambi
  • Ludovicus
  • Shakazahn
  • Silvann
  • Twists

Guide Writing:
  • Arixan
  • Bitsem
  • Gylin
  • Jame
  • Jiyambi
  • Kurich
  • Manovan
  • Snowflake
  • Svenn
Guide Coding:
  • Bitsem
  • Gameldar
  • Gylin
  • Hezkezl
  • Jame
  • Jiyambi
  • Liavan
  • AyaJulia
  • Malorajan
  • Pretzl
  • Tarix
  • MagicSN
Testing:
  • AyaJulia
  • evl
  • Mezput
  • moraller
  • tash
  • toobulkeh
  • Tuluven
  • Twists
  • Zidomo

Comments

Estelyen's picture

Updates

Two updates for the addon (ok, a big one and a minor one) went past and the old Alliance-Icecrown guide is still in there... I didn't do all the work to revise the entire guide for it to rot on the source code page you know? ;)

Does it need further testing before you include it in the addon or did you just overlook it?

Life isn't like a box of chocolates, it's more like a jar of jalapeños: What you do today might burn your a** tomorrow.

~Garfield

Ludovicus's picture

EstIce7985

Sorry about that.  The automatic machinery only copies over files with matching guide IDs in order to avoid trouble.

I'll copy it by hand and later updates wil be automatic.

There are two other guides that were not updated automatically:

I'll clean them up today as well.

updated brainfart

Before the update the addon was working great, gained 7 levels in one day. However, since the update as soon as I log in I get an error message. I tried to copy and paste the message but couldn't, the error was coming from the parser. wish I could be more helpful. Thanks for all the hard work

Ludovicus's picture

Trapping Errors

If you were to install Swatter from http://auctioneeraddon.com/dl/AddOns/!Swatter-5.10.5079.zip you might be able to catch the error and report it in more detail.

I think Blizzard changed some interfaces in 4.0.6 and some of my other addons have had problems and have issued updates over the past few days.

 

 

Hope this helps


Date: 2011-02-11 08:13:47
ID: 1
Error occured in: Global
Count: 1
Message: ...ce\AddOns\WoWPro_Leveling\WoWPro_Leveling_Parser.lua line 211:
attempt to index field '?' (a nil value)
Debug:
(tail call): ?
...ce\AddOns\WoWPro_Leveling\WoWPro_Leveling_Parser.lua:211:
...ce\AddOns\WoWPro_Leveling\WoWPro_Leveling_Parser.lua:176
...ce\AddOns\WoWPro_Leveling\WoWPro_Leveling_Parser.lua:261: LoadGuide()
WoWPro\WoWPro_Broker.lua:39: LoadGuide()
WoWPro\WoWPro.lua:173:
WoWPro\WoWPro.lua:90
(tail call): ?
[C]: ?
[string "safecall Dispatcher[1]"]:9:
[string "safecall Dispatcher[1]"]:5
(tail call): ?
Ace3\AceAddon-3.0\AceAddon-3.0.lua:543: EnableAddon()
Ace3\AceAddon-3.0\AceAddon-3.0.lua:635:
Ace3\AceAddon-3.0\AceAddon-3.0.lua:621
[C]: LoadAddOn()
..\FrameXML\UIParent.lua:244: UIParentLoadAddOn()
..\FrameXML\UIParent.lua:318: TimeManager_LoadUI()
..\FrameXML\UIParent.lua:519:
..\FrameXML\UIParent.lua:494
AddOns:
Swatter, v5.9.4960 (WhackyWallaby)
Ace3, v
Atlas, v1.18.2
AtlasBattlegrounds, v1.18.2
AtlasDungeonLocs, v1.18.2
AtlasOutdoorRaids, v1.18.2
AtlasTransportation, v1.18.2
AtlasLoot, vv6.02.00
AtlasLootBurningCrusade, vv6.02.00
AtlasLootCataclysm, vv6.02.00
AtlasLootClassicWoW, vv6.02.00
AtlasLootCrafting, vv6.02.00
AtlasLootWorldEvents, vv6.02.00
AtlasLootWrathoftheLichKing, vv6.02.00
Bagnon, v2.16.0
BagnonForever, v1.1.2
BagnonTooltips, v
DBMBurningCrusade, v
DBMCore, v
DBMLDB, v
DebugLib, v5.1.DEV.275
Omen, v3.1.0
Overachiever, v0.60
RatingBuster, v
Recount, v
SlideBar, v5.9.4960 (WhackyWallaby)
Stubby, v5.9.4960 (WhackyWallaby)
Titan, v5.0.2.40000 - Revision 519
TitanBag, v5.0.2.40000
TitanClock, v5.0.2.40000
TitanGold, v5.0.2.40000
TitanLocation, v5.0.2.40000
TitanLootType, v5.0.2.40000
TitanPerformance, v5.0.2.40000
TitanRepair, v5.0.2.40000
TitanVolume, v5.0.2.40000
TitanXP, v5.0.2.40000
TomTom, vv40000-1.2.1-beta
WoWPro, v2.1.3
WoWProLeveling, v2.1.3
BlizRuntimeLib_enUS v4.0.6.40000
(ck=441)
Thanks for the help
Ludovicus's picture

Trapping Errors

If you were to install Swatter from http://auctioneeraddon.com/dl/AddOns/!Swatter-5.10.5079.zip you might be able to catch the error and report it in more detail.

I think Blizzard changed some interfaces in 4.0.6 and some of my other addons have had problems and have issued updates over the past few days.

 

 

redownloaded the latest


Date: 2011-02-11 11:23:09
ID: 1
Error occured in: Global
Count: 1
Message: ...ce\AddOns\WoWPro_Leveling\WoWPro_Leveling_Parser.lua line 211:
attempt to index field '?' (a nil value)
Debug:
(tail call): ?
...ce\AddOns\WoWPro_Leveling\WoWPro_Leveling_Parser.lua:211:
...ce\AddOns\WoWPro_Leveling\WoWPro_Leveling_Parser.lua:176
...ce\AddOns\WoWPro_Leveling\WoWPro_Leveling_Parser.lua:261: LoadGuide()
WoWPro\WoWPro_Broker.lua:39: LoadGuide()
WoWPro\WoWPro.lua:173:
WoWPro\WoWPro.lua:90
(tail call): ?
[C]: ?
[string "safecall Dispatcher[1]"]:9:
[string "safecall Dispatcher[1]"]:5
(tail call): ?
Ace3\AceAddon-3.0\AceAddon-3.0.lua:543: EnableAddon()
Ace3\AceAddon-3.0\AceAddon-3.0.lua:635:
Ace3\AceAddon-3.0\AceAddon-3.0.lua:621
[C]: LoadAddOn()
..\FrameXML\UIParent.lua:244: UIParentLoadAddOn()
..\FrameXML\UIParent.lua:318: TimeManager_LoadUI()
..\FrameXML\UIParent.lua:519:
..\FrameXML\UIParent.lua:494
AddOns:
Swatter, v5.9.4960 (WhackyWallaby)
Ace3, v
Atlas, v1.18.2
AtlasBattlegrounds, v1.18.2
AtlasDungeonLocs, v1.18.2
AtlasOutdoorRaids, v1.18.2
AtlasTransportation, v1.18.2
AtlasLoot, vv6.02.00
AtlasLootBurningCrusade, vv6.02.00
AtlasLootCataclysm, vv6.02.00
AtlasLootClassicWoW, vv6.02.00
AtlasLootCrafting, vv6.02.00
AtlasLootWorldEvents, vv6.02.00
AtlasLootWrathoftheLichKing, vv6.02.00
Bagnon, v2.16.0
BagnonForever, v1.1.2
BagnonTooltips, v
DBMBurningCrusade, v
DBMCore, v
DBMLDB, v
DebugLib, v5.1.DEV.275
Omen, v3.1.0
Overachiever, v0.60
RatingBuster, v
Recount, v
SlideBar, v5.9.4960 (WhackyWallaby)
Stubby, v5.9.4960 (WhackyWallaby)
Titan, v5.0.2.40000 - Revision 519
TitanBag, v5.0.2.40000
TitanClock, v5.0.2.40000
TitanGold, v5.0.2.40000
TitanLocation, v5.0.2.40000
TitanLootType, v5.0.2.40000
TitanPerformance, v5.0.2.40000
TitanRepair, v5.0.2.40000
TitanVolume, v5.0.2.40000
TitanXP, v5.0.2.40000
TomTom, vv40000-1.2.1-beta
WoWPro, v2.1.3
WoWProDailies, v2.1.3
WoWProLeveling, v2.1.3
BlizRuntimeLib_enUS v4.0.6.40000
(ck=459)

this is the error message I get, thanks for the help

Which guide and which faction

If you can provide the faction, guide, and quest you were working on, we might be able to reproduce the error.

addon brainfart

Alliance, was in thousand needles. Downloaded the latest version, and as soon as I log in I get an error message. As I said though it will not allow me to copy and paste, though the message was saying the error occured in the parser lau. Don't remember the full name of the file.

Ludovicus's picture

I wrote some debugging code ...

I wrote some code that loaded ALL the guides to see if there was a parsing error.

I have reproduced your error and found a few others.  Stand by!

 

 

Ludovicus's picture

Whoops!

There are errors in the following guides that had "&" characters in the text and some long text lines.

# modified: WoWPro_Leveling/Alliance/20_25_Wkjezz_Ashenvale.lua
# modified: WoWPro_Leveling/Alliance/25_30_Savagefool_Northern_Stranglethorn.lua
# modified: WoWPro_Leveling/Alliance/25_30_Wkjezz_Stonetalon_Mountains.lua
# modified: WoWPro_Leveling/Alliance/30_35_Crackerhead22_Hinterlands.lua
# modified: WoWPro_Leveling/Alliance/30_35_Wkjezz_Desolace.lua
# modified: WoWPro_Leveling/Alliance/30_35_Wkjezz_Southern_Barrens.lua
# modified: WoWPro_Leveling/Alliance/35_40_Bitsem_Western_Plaguelands.lua
# modified: WoWPro_Leveling/Alliance/35_40_Wkjezz_Dustwallow_Marsh.lua
# modified: WoWPro_Leveling/Alliance/35_40_Wkjezz_Feralas.lua
# modified: WoWPro_Leveling/Alliance/40_45_Wkjezz_Thousand_Needles.lua
# modified: WoWPro_Leveling/Alliance/45_50_Wkjezz_Tanaris.lua
# modified: WoWPro_Leveling/Alliance/50_55_Wkjezz_Winterspring.lua
# modified: WoWPro_Leveling/Alliance/70_70_Crackerhead22_Shadowmoon.lua
# modified: WoWPro_Leveling/Alliance/74_75_Jame_Dragonblight.lua
# modified: WoWPro_Leveling/Alliance/79_80_Cyberlamb_Storm_Peaks.lua
# modified: WoWPro_Leveling/Alliance/84_85_Arixan_Twilight_Highlands.lua
# modified: WoWPro_Leveling/Horde/01_12_Snowflake_Eversong_Woods.lua
# modified: WoWPro_Leveling/Horde/05_12_Malorajan_Lost_Isles.lua
# modified: WoWPro_Leveling/Horde/12_20_Bitsem_Azshara.lua
# modified: WoWPro_Leveling/Horde/20_25_Bitsem_Ashenvale.lua
# modified: WoWPro_Leveling/Horde/25_30_Wkjezz_Northern_Stranglethorn.lua
# modified: WoWPro_Leveling/Horde/40_45_Jiyambi_Thousand_Needles.lua
# modified: WoWPro_Leveling/Horde/65a_67a_Jame_Terokkar_Forest.lua
# modified: WoWPro_Leveling/Horde/65s_67s_Jame_Terokkar_Forest.lua
# modified: WoWPro_Leveling/Horde/70_71_Jame_Howling_Fjord.lua
# modified: WoWPro_Leveling/Horde/73_75_Jame_Dragonblight.lua
# modified: WoWPro_Leveling/Horde/84_85_Liavan_Twilight_Highlands.lua
# modified: WoWPro_Leveling/Neutral/69_70_Crackerhead22_Netherstorm.lua

I will re-issue the download.

many thanks

You have my thanks, I have actually been playing for a few years and your addon has helped me level much quicker. thanks for all the hard work

Skully0815's picture

Ashenvale horde

Hey, I dont know what happened, but the horde ashenvale guide seems pretty screwed since the update last night... I was in the middle of the guide when I did the update, but now its missing a great lot of quests that were in the previous version... Pretty annoying. I hope it's just a wrong file in the update or something like that.

Estelyen's picture

Alliance Icecrown Guide

I wasn't really happy with the questing guide the addon uses for Alliance-Icecrown, seems to me like it was copied over from an unfinished Horde-Guide (some of the QIDs were of Horde quests) so I decided to write my own and would now like to share it with you. I'm posting it here in the comments since I'm not allowed to write in the forums with my newly created account :P

http://www.load.to/CE4l7fBmfs/79_85_Estelyen_Icecrown.zip

The guide is playtested partially since I had already completed most of the quests around the Shadow Vault (in this guide from "It's All Fun and Games" until "Blackwatch") before I decided to make my own guide and to test the part I already completed I would have to create a new character and level him up first :P

Life isn't like a box of chocolates, it's more like a jar of jalapeños: What you do today might burn your a** tomorrow.

~Garfield

Gylin's picture

Testing

Any time a PTR is up, testing is easy, as you can make a max level character and test with that

Jiyambi's picture

What you have is almost

What you have is almost certainly superior to what we had for Alliance Icecrown. I give my permission for you to copy it into the source code page for that guide if you like (and it would be most helpful if you wanted to do so!). Make sure to replace the author name with your own so you get credit.

I'm pretty sure the old guide was simply a straight up Tour Guide recording that one of our users did, which records a lot less information than even our recorders most basic setting, so what you have is most certainly an upgrade!

Estelyen's picture

How to edit

http://wow-pro.com/node/3301 Is this the source code page you mean? How do I copy my guide into it? If I click on "fix bugs on this page" it tells me I don't have permission to access that part of the site.

Life isn't like a box of chocolates, it's more like a jar of jalapeños: What you do today might burn your a** tomorrow.

~Garfield

Jiyambi's picture

Ah, let me upgrade you to

Ah, let me upgrade you to Trusted Member. You should be able to edit it now. Sorry about that! :)

Thanks

Thanks alot good job for the guide


Thanks!

Couple of errors I saw

Your addon has been great for me, however in the current zone i'm in it is flawed (Ice Crown Citadel)

In the first few quests at least (im have not completed it yet) I the arrow hasn't come up so it has been harder to find the quests.

Also, the order on which I have been getting quests has been a little off of what it should be (tells me to not get a quest which is right next to me, then go back to get it) its not anything substantial as I still tells me to get all the quests before I leave.

But thanks for the guide overall! It has been great!

If you'd like I can keep someone posted on how the rest of the zone goes. Just lmk. thanks

 

Crackerhead22's picture

Most of Icecrown does not

Most of Icecrown does not have the cords in the lua file. So unfortunately you will have to use an addon like Lightheaded for the cords, until we can get all the cords in place.

Doesn't work

It doesn't work for me at all.

Back in WOTLK everything worked great.

5 minutes ago I have been downloading the addon and TomTom and after creating a new worgen and after logging in I got a lua error.

Some problem with TomTom :(

I don't get the arrow but some weired lua error message as soon as I am logged in.

Seems as if the guide sends wrong coordinates or something.

 

message:

Bad argument #4 to

'Astrolabe.Interface\AddOns\TomTom\Astrolabe\Atsrolabe.lua:

877' (number expected, not nil)

Time : 01/28/11 11:53:02

Count: 1

Stack: [C]: in function 'error'

 

I already tried different versions of the guide, but nothting works =/

Does anybody know, how to fix this problem?

Ludovicus's picture

This is a bug in TomTom ...

I tracked down the bug in TomTom that was causing the errors in Astrolabe.  I gave some pactches to  Cladhaire (the author of TomTom), but he is not sure when he will get around to reviewing them or fixing the probem.

I also had tried to get in touch with Esamynn, the author of Astrolabe, to confirm the correctness of my fixes, but he has not gotten back to me.

The error will pop up in many instances or in phased zones or in maps with floors (like the drag in Orgm).

 

 

Ludovicus's picture

TomTom v40000-1.2.0-beta issued 2011-01-24

http://wow.curseforge.com/addons/tomtom/files/42-v40000-1-2-0-beta/

Download and install at your own risk. I have not verified if it fixes my issues yet.


Tag v40000-1.2.0-beta
8ad462d4394833651298f81ce8009ca01a4fa35d
James Whitehead II
2011-01-24 16:00:43 +0000
tagging v40000-1.2.0-beta
--------------------
James Whitehead II:
- Initial update to POI integration plugin
Currently, most of the old features should work properly, only there is
now a limitation that it will only work with objective waypoints that
are in your current zone, in particular with the ones on the watch
frame. I will likely change it so that the ones on the world map work
properly, but this will be in a separate commit.
- Add a function to indicate if the crazy arrow is empty
- Add a tag to make it easier to find core logic
- Fix non-zone slash command
- Updated based locale file
- Fixed slash commands for /way reset and /way

Ludovicus's picture

TomTom Beta 1.2.0 Code Review

I've done a review of the changes made in the beta release 1.2.0 of TomTom.

All of the troublesome code dealing with (continent,zone,x,y) quads has been updated to use the new (map,floor,x,y) quads.

The patches I made are superseeded by this rework.   I'll start using it and see how it works for me.

Silvann's picture

Is that beta version already

Is that beta version already the one from TomTomLite? The map library used there (same I'm using on our arrow module) should work anywhere, including different floors of a map. Hopefully TomTom's public APIs won't change much...

Ludovicus's picture

API Compatability

The public APIs pretty much work the same way.

I just ran a worgen toon through to level 5 to test out the guide.   When I tried the guide in December, dreadful LUA errors and warnings about zones not being found happened.

Now WowPro and TomTom seem to play nice.

Crackerhead22's picture

Astrolabe is a TomTom error. 

Astrolabe is a TomTom error.  I'm assuiming your in an error where that has no map name, such as the Worgen area.  Though I thought there was a fix to stop that from happening in the latest.

Gylin's picture

Although it is a

Although it is a TomTom/Astrolabe error, even Carbonite gives wrong cords in phased areas. The Deathknight start zone suffers exactly the same, TomTom throw similar errors with no arrow, Carbonite arrow point to the middle of the ocean between EK and Kal'.

My hope is that the instance guide module and our own arrow allows us to fix this problem with phased zones. 

Worgen Guide For WoW Pro Addon

I just wanted to let someone know that in the Worgen guide, the step to accept and complete the quest "Last Chance At Humanity" is not there. Along with this i have found that the quest "Alas, Gilneas!" is not on there. I wanted to get that out there so that it could be updated and more complete. Thank you for your time and the wonderful add-on. I have been using it for only a short while and I'm already loving it.

Ludovicus's picture

Missing Steps in the Worgen Guide

BloodFang:  

I have a trial correction for the guide to add the two quests you mentioned.

It turns out to be a little more involved than I expected, as [Last Chance At Humanity] is accepted and turns in automatically.

Jiyambi, I used the standard "A" and "T" steps for the quest.   Is it kosher to have just an "A" step with no "T" if the quest auto-turns in?

 

Gylin's picture

Auto turn in

I'd say yes, as we don't need to tell a user to turn it in if it does so automatically

true

that´s true

Ludovicus's picture

Yuck

It turns out that since auto-turnin quests never hit your quest log, the event that is used to auto complete is never seen.

They need to be listed as "N" steps with an "NC" tag.   Annoying.

Anyways, I ran two worgen through level 8 to test things out.  The guide needed a few other tweaks as well.

(Can we say OCD?)

last version

what is the last version of Wow??

Gylin's picture

Yes we can :P

Yes we can :P

In Vash, I've noticed 2 small errors, one a cord was off, the other a target "X" mob, use "Y" item, and no buttons for either

 

Ludovicus's picture

I knew we could ...

LOL, I just corrected ~10 guides so that the RegisterGuide calls on this website were in sync with GIT.

Things just have to be in the right place and be neatly put away ...

Cannot wait to get this!!!

Cannot wait to get this!!!

Deepholm Guide

First off, love the guides. leveled 1-82 in 5 days played because of them, theyre great. Im having trouble with the Deepholm Guide though.


 


I get to the step at the beginning to ride on the back of the Wyvern to enter the area. When I got off the bat, the step didn't complete so I manually clicked it off. That skipped me to step 127 of the guide and made a huge list of all the quests I skipped in the middle of my screen. I would really like to solve this problem so I can use the guides again and get back on the fast track to 85.

Jiyambi's picture

It should be stated in an in

It should be stated in an in game tooltip - RIGHT-click to manually check off a step!

Left click causes the addon to try to skip the step, which will in turn skip any steps that depend on it. This is INTENTIONAL for people who want to skip steps!

An issue with the guides

I like the add-on, and it helps quite a bit when I've been able to get it to work.  However, today when I started a worgen, the leveling add-on was shifting to the bottom step of each guide and giving me a waypoint, through TomTom, to that place.  I'd remove the waypoint, move to the step of the guide where I am currently working, and keep moving.  However, each time I finish a step, the add-on would revert back to the bottom of the guide and restart the waypoint for that point.

I'm unsure if this is a unique problem, but it's a very big setback when I'm trying to use these guides efficiently.

Can anyone help?

tory bruch

Tory Burch Hauler Totes Fuxia Tory Burch bags group are already within the catwalks in addition to around showrooms and so are known intended for having a significant major reputation.

Jiyambi's picture

That is very strange. Is it

That is very strange. Is it only in that one guide with that particular character, or does it happen with other guides as well?

It started in the Worgen 1-13

It started in the Worgen 1-13 leveling guide.  That didn't really bother me too much, since I just accepted every quest to open up the next set of quests.  However, it then continued to happen in Jame's 13-20 Darkshore guide.  It had wanted me to collect the Seed of the Earth from Onu, which is halfway down the Darkshore area, and I was only just coming into the zone. 

I don't think there's any other information I haven't given.  But I'm not sure of any technical questions within the add-on itself.

Jiyambi's picture

Hmmm. Alright, I'll see what

Hmmm. Alright, I'll see what I can find. For now I'd suggest deleting the character-specific and account-wide WTF for WoW-Pro and see if that fixes it.

I have done that, but it

I have done that, but it didn't help with the problem.  Would it possibly be add-on interference?  I have several add-ons.

Atlasloot, Everyquest, AutoVendor, FlightMap, MapCoords, TomTom, WoW-Pro, and WoW-Pro Leveling.

Have any of these caused problems with this add-on in the past?

Jiyambi's picture

Not that I know of, but you

Not that I know of, but you could test by trying to load just our guide and see if the problem continues.

It sounds to me like the addon thinks you have completed all of those quests before, as if their IDs are in your table of completed quest IDs. The fact that it persists after you wipe your character-specific saved variables is VERY strange, though.

By any chance did you have a character with this same name before? I've had issues with that in the past.

No, I've never had a

No, I've never had a character with the same name before.  I actually only saw the problems after I upgraded to Cataclysm and upgraded all of my add-ons.

Do the different guides set an auto-waypoint?  Is there a way to set/unset waypoints within the guide so that, upon completion of the current step, it doesn't revert me back to the last step (and giving me a waypoint with that?)

Jiyambi's picture

Oooooo. I think I

Oooooo. I think I misunderstood you. It's just the ARROW that's skipping, not the rest of the guide?

I'm still not sure why it should be doing this, but that will give me some idea of what's happening.

It's working simultaneously. 

It's working simultaneously.  The guide has a highlighted step that it likes to continuously go back to after I complete a step.

I figured out that if I wheel-click and then left click, I can set a different waypoint, but it doesn't really help me just flow into the next steps.  I still get stuck on THAT step until I wheel-click and then left click on the next step that I want it to stick on.

TomTom doesn't really feel to be the culprit here.